Nissan Juke Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2017 juke tekna cvt and until recently the rear washers were fine. Now when you operate the washer control nothing comes out of the jets. I thought they might be blocked so took the tube off the jet and tried but still nothing came out. I then removed the trim around the tailgate and tried to check any connections that were under there. All look OK and no leaks. I then noticed what I think may be a pump as has 3 tubes going to it...can anyone verify this..see pic. I also noticed the tubes going from this to something where the rear camera is as well...not sure what that is. Also when the washer switch is operated water sprsys in a stream from what looks like the camera on the tailgate.
Car Motor vehicle Automotive design Automotive tire Steering part
Vehicle Grille Motor vehicle Hood Automotive lighting
Hood Automotive lighting Bumper Automotive exterior Automotive design
 

·
Super Moderator
Joined
·
740 Posts
Hi Jim, welcome to the forum, you don't say if your car is still under warrant or not, if it is let your dealer sort it for you if not then I would take the cover off after disconnecting the power plug and see if the water pipes are clear and it is normal for the camera to have a water supply to keep it clean. On the early models the Juke only had one pump for the washers and this was fitted onto the windscreen washer bottle, it all depends on whether you are good at tinkering if you are then nothing to fear, please let us know how you get on.
 
1 - 3 of 3 Posts
Top